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CHAPTER 01: UNDERSTANDING PDF FORMS
Although HTML-based web forms are 
quite popular, fillable PDF forms are still 
quite common for certain applications. But 
adding accessibility to the job of making 
fillable form fields in a PDF can seem like 
an insurmountable task for some users. The 
problem stems from the fact that Adobe 
Acrobat doesn’t do anything to facilitate the 
process. If you’ve ever added form fields 
to an existing PDF file and ran the Acrobat 
Accessibility Checker, you were probably 
greeted with a slew of new errors that hadn’t 
existed prior to your adding the form fields. 
This can feel overwhelming, but I’m here 
to tell you that making accessible forms is 
not only possible, but once you have the 
knowledge, it’s not even that hard. So, let’s 
dive in and take a look at how to create 
accessible, fillable form fields using a couple of 
different approaches.

Methods for Creating 
Fillable PDF forms
There are two main approaches you can 
take to create fillable and accessible PDF 
forms. One typical approach is to start with 
an existing PDF file, add the appropriate form 
fields in Acrobat, and make the document 
accessible from there. This is a common (and, 
obviously, necessary) approach when you’re 
not the designer of the form and, instead, are 
relying on someone else to do that work.

Another approach, which is much more 
proactive and provides more control and 

efficiency, is to use Adobe InDesign to construct 
your form. InDesign not only provides amazing 
design capabilities, it also allows you to add 
fields that become live, fillable form fields 
when exported to the PDF format. I know of 
no other application that provides the ability to 
export to a fillable PDF form.

Create a Fillable PDF Form 
from an Existing PDF
When you begin the process of creating a 
fillable form from an existing PDF file, my 
first recommendation is to make sure that 
the PDF is accessible before you get started 
(FIGURE 1). Check that the document is 
tagged appropriately and contains all of the 
elements to make it accessible. Doing this 
streamlines the process and makes it easier 
to continue from there. Failure to do this 
can create a seemingly insurmountable task, 
especially for beginners.
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FIGURE 1. Make sure your document is tagged and 
accessible before adding form fields to the PDF docu-
ment.
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CHAPTER 2: PDF FORMS IN ADOBE ACROBAT

Using the Prepare Form Tool
With your accessible foundation in place, 

you can begin adding form fields to the PDF 
file. Start by choosing the Prepare Form tool 
in Acrobat.

You can find the Prepare Form tool by 
clicking the Tools tab at the top left of the 
screen and choosing it, or if you’ve made it a 
default tool, it will be in the tools on the right 
side of the screen. A screen will be displayed 
giving you the ability to start the process with 
the file you have open or with a different file 
of your choosing. By default, the Automatically 
Detect Form Fields preference will be enabled

FIGURE 2. By default, Adobe Acrobat has form field 
auto-detection enabled, but you can turn this off by 
clicking Change.

Form field auto-detection evaluates your 
form and tries to determine where form fields 
are needed, as well as what type of form 
fields are needed. The accuracy of form field 
auto-detection leaves a bit to be desired. For 
fairly simple forms it can do a pretty good job, 
but more complicated forms often result in 
missing fields or fields created at the wrong 
location and/or of the wrong type. For this 
reason, I prefer to add my form fields manually 

to increase the accuracy of my form fields. 
However, using form field auto-detection 
in no way inhibits your ability to make the 
fillable form accessible. If you want to turn off 
form field auto-detection, click Change on this 
screen and turn off Automatically Detect Form 
Fields in the Preferences.

With Prepare Form activated, you can choose 
the type of form field you’d like to add from 
the options at the top of the screen. All form 
fields can be made accessible so the type of 
form field you choose is dependent upon the 
requirements for your form. After selecting a 
form field tool, when you move your pointer 
over an area of the form, you’ll see a ghosted 
shape of the form field you’re about to create. 
To create a form field at the size displayed, 
simply click anywhere on your form. To 
customize the size of the form field, click and 
drag to establish the size of the field (FIGURE 3).

FIGURE 3. Either click or click and drag to add a form 
field to the PDF document.

Upon adding the form field, a yellow pop-up 
window will appear giving you the ability to 
define the name for the form field. Although 
the name has no value for accessibility, it is 
helpful for keeping form fields organized and 
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for helping you to easily identify a form field 
in the future (FIGURE 4). Give the field an 
appropriate name, then click anywhere in the 
document to deselect the field. If at any point, 
you want to change the name of the form field 
or adjust any of the form field properties, you 
can simply double-click the form field using 
the Selection tool (black arrow) to display the 
Form Field Properties dialog box.

FIGURE 4. Give the form field a name immediately after 
adding the form field to the document.

Continue adding form fields to the PDF 
document as needed using the various form 
field types. In this article I want to stay focused 
on the accessibility requirements of PDF forms, 
but if you need more guidance and direction 
on form design and creation, check out my 
article Creating accessible PDF Forms in 
InDesign (this article is members only).

Accessibility requirements
So, you’re making good progress, your form 
is looking good. It’s functional, and it’s doing 
what you want, but now you need to make 
sure that it’s accessible. If you run the Acrobat 
Accessibility Checker on the file now, you’ll be 
greeted with a mountain of errors (FIGURE 
5). Truly, Acrobat doesn’t do you any favors 
from an accessibility standpoint. One of the 
errors is called Field Descriptions—Failed. 

Field descriptions describe what the user is 
supposed to enter into each respective form 
field. By default, the field description (tooltip) 
is blank for each form field that you create. 
Because this is an accessibility requirement, 
you’ll receive an error until you add a tooltip 
(field description) for each field.

FIGURE 5. You’ll see several errors in the Acrobat 
Accessibility Checker after adding form fields to your 
document.

https://creativepro.com/creating-accessible-pdf-forms/
https://creativepro.com/creating-accessible-pdf-forms/
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Adding a tooltip is a simple step. Go back 
into Prepare Form mode and double-click any 
of the form fields you added to display the 
Form Field Properties dialog box. Under the 
General tab, find the Tooltip field and enter 
a description of what the user is expected to 
enter into that field (FIGURE 6). This tooltip is 
important as it is voiced by assistive technology 
when a user is reading the form. Be concise and 
direct when describing what the user should 
enter into a field. No need to say “Please enter 
your residen-tial address here”; simply “Enter 
your residential address” is sufficient. Note that 
radio buttons share the same tooltip across 
all buttons. So, for radio buttons make the 
tooltip more general such as, “Choose which 
computer platform you use.”

The other errors you will see after running 
the Acrobat Accessibility Checker will be either 
“Tagged annotations - Failed” or “Tagged form 
fields - Failed” depending on the type of form 
fields you’ve added to your document. This is 
where Acrobat really drops the ball.

FIGURE 6. Adding a tooltip (field description) to a 
form field

Tagging Form Fields
Even though you’re working in a tagged 
document, Acrobat fails to tag new form fields 
as you add them, which is why you receive 
the error.

There are two approaches you can take to 
addressing these errors. The first approach 
is more manual. In the Tags pane, make 
sure the Tags object is selected. Now open 
the Accessibility tool in Adobe Acrobat, and 
click Reading Order to display the Reading 
Order panel. Using your pointer, select a form 
field (paying attention to only selecting the 
form field and not any other elements), then 
click the Form Field button in the Reading 
Order panel to tag the selected form field 
as a <Form> tag (FIGURE 7). The purpose 
of selecting the Tags object in the beginning 
was to ensure that the new form field tags 
are added at the <Root> level of the tag 
structure. If you fail to do this step, new tags 
will be nested within the currently selected 
tag, which is usually wrong. You would then 
repeat this process for each form field. Sounds 
like a lot of work? It can be. But read on for a 
more automated method that is much faster 
in some cases.

To speed up the process,Acrobat also offers 
a method of tagging form fields in which you 
can do a find/change of sorts to automate 
the process. Once again, start by clicking the 
Tags object in the Tags pane. Now, click on 
the Options button ( ) at the top of the 
Tags pane and choose Find to display the Find 
Element dialog box.
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From the Find menu, choose Unmarked 
Annotations, choose the Search Document 
option in the Type section, and click the Find 
button to find the first untagged form field in 
the document. Acrobat will highlight the first 
untagged form field in the document. Click 
the Tag Element button to display the New 
Tag dialog box where you need to select Form 
from the Type menu, and then OK to tag the 
currently selected form field with a <Form> 
tag and advance to the next untagged form 
field (FIGURE 8). Continue clicking the Tag 
Element button to tag the remaining untagged 
form fields until the Find Completed dialog 
box is displayed indicating that all untagged 
form fields have been tagged.

Finishing touches
At this point we’re almost finished. The 

only remaining issue is one that the Acrobat 
Accessibility Checker won’t flag: the order in 
which the tagged form fields appear in the 
tag structure. Remember, the most common 
assistive software applications (JAWS and 
NVDA) use the tag order as the order in which 
content is voiced. Currently, all your <Form> 
tags are at the bottom of the tag structure, 
which means all of the content will be read 
first and then the app will go back and read 
all of the form fields. For proper reading of the 
document, you need to nest the <Form> tags 
at the appropriate locations within the tag 
structure (FIGURE 9, NEXT PAGE). For example, 
the First Name form field needs to appear after 
the First Name text in the document. To do this, 
drag the form tag so that it is located after the 
text that the form field is associated with.

FIGURE 7. Tagging a form field using the Reading Order panel.
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FIGURE 8. Clicking the Tag Element button allows you 
to tag an object using the tag of your choosing.

You may notice in your form that any 
underlines used in the form will appear 
as objects within the tag structure of 
the document. Although it’s not strictly 
necessary, I like to mark these elements as 
artifacts to improve the reading experience 
for the end user and to clean up the tag 
structure of the document.

FIGURE 9. Nest the <Form> tags in the appropriate 
location within the tag structure of the document.

READING ORDER PANEL SELECTION TRICKS
If you’ve spent any time selecting content in the Reading Order panel, you’ll discover 
that it can be challenging to isolate your selection to a specific object without inad-
vertently selecting other elements in the process. Fortunately, Adobe Acrobat offers 
some hidden tricks to help you isolate what you’re trying to select. If you’ve created 
a selection and have too much selected, you can hold down the Option/Ctrl key and 
click and drag to remove elements from a selection. Conversely, if you need to add 
an item to an existing selection, you can hold down the Shift key and click and drag 
to add items to an existing selection. Keep in mind that you can’t select just part of 
an object to select it. Your drag must fully encompass an object in order for that ob-
ject to be selected, added to a selection, or removed from a selection.
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CHAPTER 3: PDF FORMS IN ADOBE INDESIGN
InDesign offers a number of advantages in the 
form building process that put more control 
in the hands of the form author and that 
automate some common tasks to streamline 
the form- creation process. You should follow 
the best practice of ensuring that all the other 
content in the document is made accessible 
before adding all of the form fields. For more 
information on how to do that, see my article 
10 Steps to Accessible PDFs (this article is 
members only).

Prepare your form
To begin, lay out your form as you wish, 
leveraging the format-ting and layout features 
that InDesign has to offer. There’s no right 
or wrong way to do this, only personal 
preferences. I, for example, like to build my 
forms using a single text frame when possible. 
This reduces the number of container tags in 
the tag structure of the exported PDF file. If, 

however, you prefer to build your form using 
individual frames for each component of the 
form, you’ll need to use the Articles panel to 
set proper tag order in the exported PDF file, 
and you’ll end up with more <Sect> container 
tags. This is not ideal, but it’s acceptable in 
most cases.

From here, you can begin adding the form 
fields in InDesign that will become fillable form 
fields when the layout is exported to PDF. Start 
by drawing a frame to the size of the form field 
that you’d like to create. You can use a graphic 
frame, text frame, or unas-signed frame for this 
process. Open the Buttons and Forms panel by 
choosing Window > Interactive > Buttons and 
Forms. With the frame selected, choose the 
type of form field you want by selecting the 
appropriate option from the Type menu. The 
frame will now have a heavy dashed border 
indicating that it is an interactive form field 
(FIGURE 10).

FIGURE 10. An InDesign frame converted to an interactive form field

Once a frame is defined as in interactive 
form field, you’ll see several options available 
in the Buttons and Forms panel that you 
can customize, including the field name, 
font, font size, and most importantly from 
an accessibility standpoint, the Description 

that becomes the tooltip when the PDF file is 
generated. Adding the tooltip here in InDesign 
is more efficient and repeatable because the 
tooltip will get passed on to the PDF file each 
time you export.

https://creativepro.com/10-steps-to-accessible-pdf/
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What gives InDesign a leg up on Acrobat 
when it comes to creating fillable forms is 
that when form fields are added in InDesign, 
not only do they become fillable fields when 
the PDF file is generated, but they are also 
automatically tagged, which is a tremendous 
time-saver.

Specifying tag order is the other 
requirement you’ll need to incorporate into 
your document. Achieving appropriate tag 
order can be accomplished in one of two ways 
depending on how you build your document. 
If you used individual frames for each element 
of the form, you can use the Articles panel 
in InDesign to set the order of elements 
appropriately (FIGURE 11).

If you’ve built your form using a single 
text frame, the Articles panel can’t help you 
because it works at the object level and can’t 
drill down into the content of a frame. In this 
case, you’ll need to anchor the form fields in 
the appropriate location within the text so that 
they appear in the correct order in the Tags 
pane of the exported PDF. Do this by dragging 
the square in the upper-right corner of the 
form field frame to the location where it needs 
to appear in the text (FIGURE 12). Repeat this 
step for each form field.

FIGURE 11. Use the Articles panel to specify the tag 
order of objects in the InDesign layout.

Generate the PDF
The final step in the process is to generate 

the PDF file. Although InDesign gives you 
two choices when exporting a PDF file, only 
the PDF (Interactive) option will include the 
interactive form fields in the final PDF. The 
PDF (Print) option does not include the form 
fields. Choose File > Export, and choose PDF 
(Interactive) from the Format menu. Click Save, 
and in the Export to Interactive PDF dialog 
box, be sure to choose Include All in the Forms 
and Media section. Do the same for Create 
Tagged PDF and Use Structure for Tab Order.

FIGURE 12. Drag the blue square of the form field to 
the point in the text where you want the form field to 
appear in the tag struc ture of the PDF.
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In the resulting PDF file, you’ll notice that 
not only is the content tagged, but so are 
the form fields and those form fields already 
contain tooltips (descrip-tive text) (FIGURE 
13). Taking a quick trip over to the Acrobat 
Accessibility Checker will likely yield no errors, 
which is a considerable improvement from 
what you might have seen after initially adding 
the form fields in Acrobat.

FIGURE 13. After exporting to a PDF from InDesign, 
content is tagged, form fields are tagged, and form 
fields contain the necessary tooltip text for full com-
pliance.

The Path to Accessible PDF Forms
There’s no single correct workflow for how you 
should create your PDF forms. Your path may 
very well be determined by factors out of your 
control. Regardless of your approach,

I hope you’ve learned that there are 
several methods to achieve the desired result 
and approaches to address common errors 
encountered during the process.

READING FORMS USING 
ASSISTIVE TECHNOLOGY
It’s helpful to understand that both leading as-
sistive software appli-cations (JAWS and NVDA) 
provide a unique mode when reading a PDF form. 
The default mode in both applications is called 
Browse mode. This is the standard mode used 
when reading a document, and it’s why it’s im-
portant to organize and nest tags in a document 
appro-priately so that as a user is reading the 
content, the elements will be read logically and in 
order.

Both JAWS and NVDA also contain a Forms mode 
that changes the behavior of the screen reader so 
that it reads only the form fields and allows a user 
to enter text into those form fields. In this mode, 
the user skips over the content (static text) in the 
document and focuses on only the form fields for 
easier browsing.

As document authors, we have no control over 
which mode someone will use when reading a PDF 
form, which is why it’s important to make sure that 
the tags are ordered and structured appropriate-
ly in the event that the user chooses to read the 
form in Browse mode instead of Forms mode.
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