
#accessibilityMatters 1 www.accessibilityUnraveled.com

ACCESSIBILIT Y UNRAVELED

Training &
ConsultingCHAXChapter 01

Understanding What Makes a PDF Accessible
training@accessibilityunraveled.com
Youtube & Facebook: PDF Accessibility

Tags

What is the purpose of a tag?
In a PDF file, tags identify the textual content within a 
document and establishes it’s role in the document. 
Common tags you’ll likely see in a PDF are H1 (Heading 
Level 1), H2 (Heading Level 2), P (Paragraph), Table, etc.

The importance of tags becomes relevant when a user 
of assistive technology is reading a document. Many 
of the tags particularly the headings are voiced as the 
content is being read. For example the heading on this 
page would be voiced as TAGS heading level  2. The fact 
that the content is voiced as a heading is less important as 
the capability that is provided to the AT user as they are 
reading the document.

As a sighted user, when a newspaper, magazine, 
or on-line article is being read, headlines are used to 
segregate the information in the article or document 
to determine what content is of interest or to locate 
specific content within the document. Users of AT gain 
the same capability when a document is being read by 
tapping the H key on their keyboard. Performing this 
step reads all of the headings in the document to help 
the user understand what that section of the article or 

document is about and to determine if they’d like to 
read more about that section. Generating a PDF file with 
no headings is the equivalent of reading a newspaper 
or magazine with no headings. Your only choice is to 
read the content from beginning to end with no way to 
segregate the information.

How do I add Tags to a Document?
How tags are added to a document depends largely on 

how the PDF file is being generated. If you are starting 
with a PDF file (maybe one that is provided to you), you’ll 
need to add the tags using Adobe Acrobat or another 
3rd party application. In this situation, the process of 
adding tags to the PDF file is a very manual one. It’s time 
consuming, it’s mundane, and honestly expensive. I 
encourage users to avoid this method whenever possible 
however some situations leave the user with no other 
choice than to take this approach. 

A more reliable and powerful approach is to utilize a 
source application that provides the capability to include 
accessibility information which will be included when 
a PDF file is generated from the source file. Common 
applications that provide this capability are:

• Microsoft Word
• Microsoft PowerPoint
• Microsoft Excel
• Adobe InDesign

One of the key benefits to leveraging a source 
application when creating an accessible PDF file is 
that any attributes that you apply in the source file are 
repeatable. So if changes to the document need to 
be made, when you re-export the PDF file, all of the 
accessibility attributes will be included in the new PDF 
file. This saves a lot of re-work time. Imagine if you had 
remediated a PDF file directly only to have changes 
come in or a new file supplied. All of the work that you 
performed directly on that PDF file would have to be 
redone from the beginning.
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Microsoft Word
Microsoft Word is a really good choice as a source 
application for creating accessible PDF files. This is 
because of the popularity of Microsoft Word as an 
authoring application but also because Word provides 
tools that can be leveraged in facilitating the creation of 
an accessible PDF file.

Because Word contains a natural top-to-bottom flow, 
it’s easy to define the tag order provided you leverage 
that natural flow. Inserting elements such as text boxes 
can cause order issues when exporting to the PDF format 
from Microsoft Word.

Adding a Document Title
All accessible PDF files need a document title and that 
title needs to be displayed when the PDF file is opened in 
a PDF reader such ad Adobe Acrobat or Adobe Acrobat 
Reader. Microsoft Word gives us the ability to add a title 
that will be included when creating an accessible PDF file.

To add a title in Word, choose File > Info. In the 
Properties category on the right side of the screen, 
you’ll see an area where you can enter an appropriate 
document title. Although the title is the only required 
metadata element for accessibility, because these 
documents will likely be published on-line, it can be 
beneficial to add other metadata that will carry over to 
the PDF file including:

• Tags (keywords)
• Subject
• Author

Microsoft Word defines the logged in user of the person 
creating the document as the author. This typically 
doesn’t make sense for a published document. You can 
right-click on an existing author and choose “remove 
person” and then type in a new author in its place.

Metadata properties can be added in Word by choosing File > Info.

Defining Tags

Default Styles in Word
In order for content to output as the appropriate tag in an 
exported PDF file, it’s imperative that styles are used to 
format text in a Word document. The easiest way to apply 
the appropriate heading tags to text in a PDF is to use the 
default heading styles in Microsoft Word. Those default 
heading styles are named:

• Heading 1
• Heading 2
• Heading 3
• Heading 4
• Heading 5
• Heading 6

Although Word contains more than six heading levels, 
only headings 1 through 6 will map to the appropriate 
tags in the PDF file. A lot of Word users are put off by the 
default appearance of the headings but it’s important to 
remember that you can modify the appearance of those 
styles very easily by changing the appearance of the 
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text to your desired appearance and then clicking to the 
right of the style name in the Styles pane and choosing 
“Update [style name] to match selection”.

Custom Styles in Word
Sometimes you may choose to create your own style 
from scratch instead of using one of the default styles in 
Word. This is a fine approach, however if that style is to 
serve as a heading at any level, it will not work by default 
as user-created styles will always map to a <P> tag in the 
exported PDF. In order to get a user-created style to map 
to any tag other than a <P> tag, special care must be 
taken.

To control what tag the user-created style will map to, 
click on the triangle to the right of the name of the style 
in the Styles pane, and choose Modify. In the Modify Style 
dialog box, click on the Format button in the lower-left 
corner of the dialog box and choose Paragraph. In the 
Paragraph dialog box, you’ll see an Outline level drop-
down menu. The default outline level is Body Text which 
maps to a <P> tag in the exported PDF file. But Level 1, 
Level 2, etc. maps to the equivalent heading tag in the 
exported PDF file.

Defining the outline level in a Microsoft Word style.

Bulleted and Numbered Lists
When creating lists in Microsoft Word, it’s important 

to leverage the bulleted or numbered list formatting 
buttons located in the Home tab of the ribbon. Using 
these buttons will not only automatically apply bullets or 
numbers to selected text, but it will also ensure that they 
will be tagged as a list in the exported PDF document. 
Lists can be customized in Microsoft Word to use items 
other than a standard bullet or to use letters, roman 
numerals, etc. for numbered lists.

Navigation Benefits
A side-benefit of using the default heading styles in 

Word and customizing styles to use outline levels, is that 
the Navigation pane in Word populates with the text that 
has those styles applied.

The benefit of the Navigation pane is that it makes it 
very easy to see how headings are applied in a document 
and how the document is structured. In addition, the 
Navigation pane can be used to quickly and easily 
navigate throughout the document by clicking on an item 
within the Navigation pane.

Heading styles in Word appear in the Navigation pane for easy 
structure analysis.
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Creating PDFs

Microsoft Method
Microsoft Word provides possibly two methods of 
creating an accessible PDF file depending on your setup. 
The first method is achieved by choosing File > Save As 
or File > Save A Copy and choosing PDF from the format 
drop-down menu. To define the accessibility properties of 
the PDF, click on the More options link below the format 
drop-down menu.

Choose PDF from the Format drop-down menu.

Now click on the Options button at the bottom of the 
dialog box. In the Options dialog box, make sure that the 
following options are chosen:

• Create bookmarks using headings
• Document properties
• Document structure tags for accessibility.

These three options do a lot including adding the 
document metadata from Word to the PDF. Adding tags 
to the PDF, and adding bookmarks in the PDF file based 
on the heading styles used. With these properties set, 
click OK and save the PDF file. The resulting PDF will be 
tagged, contain bookmarks, and include the metadata 
added from Word.

As an aside, bookmarks are required for documents 
containing 9 or more pages. Including bookmarks in the 
PDF file satisfies this requirement.

Defining the accessibility properties in the Options dialog box.
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Adobe Method
If you’ve installed Adobe Acrobat Pro on your computer, 
the installer will add a component to the Office 
applications on your computer (including Microsoft Word) 
called the PDFMaker. The PDFMaker is an Adobe plug-in 
for Microsoft Word that adds the capability to create PDFs 
(including accessible ones) from Microsoft Word.

To see if the PDFMaker is installed on your computer, 
open Microsoft Word and look at the tabs above the 
Ribbon in the Word interface. If the PDFMaker is installed, 
you’ll see an Acrobat tab above the Ribbon.

The Acrobat tab in Microsoft Word indicating that the PDFMaker 
has been installed.

Click on the Acrobat tab to make it active. Now click on 
the Preferences button to control the properties of how 
the PDF file will be generated.

In the Acrobat PDFMaker dialog box, make sure that the 
following options are enabled:

• Convert Document Information
• Create Bookmarks
• Add Links
• Enable Accessibility and Reflow with Tagged PDF

Enabling these options will ensure that you create 
a tagged PDF with all of the necessary accessibility 
elements. Notice that this is where you control whether 
bookmarks will be created in the exported PDF file.

Setting the appropriate accessibility options in the Acrobat PDF-
Maker dialog box.
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Tables
In an accessible PDF files, tables require special attention. 
Probably most importantly, every table requires a header 
row. That header row can be at the top of the table, or 
along the left edge of the table (first column) or both. But 
without a header row, the table will fail validation in all 
checkers.

The value of a header row is to provide the user with 
a category for the data cells in a table. The header cell is 
voiced before the value of the data cell, letting the user of 
AT know what the heading is for that information.

Microsoft Word makes it easy to add a header row to 
a table. To do so, simply click in the table in which you 
want to add a header row, then click on the Table Design 
tab above the Ribbon. To the far left of the Ribbon, 
you’ll see the Table Style Options section which includes 
checkboxes to add both a Header Row (the top row of 
the table) and a First Column (the left most column of the 
table).

Although Microsoft Word does a pretty good job of 
adding header rows to a table, the feature isn’t complete. 
For accessibility, header rows need to either have cell 
IDs created to associate data and header cells (for 
complex tables), or the scope defined for the header cells 
(column, row, or both). Microsoft does neither of these so 
regardless of what you do, some additional touch-up is 
required in Adobe Acrobat after the PDF file is generated.

Additionally, one area where Microsoft Word fails 
significantly is when cells are merged in a table. Those 
merged cells are not handled well in the exported PDF 
and will definitely require additional remediation in 
Adobe Acrobat after the PDF file is generated.

Enabling header rows for a table in Microsoft Word

Hyperlinks
Hyperlinks are an important part of a PDF file as they 

provide a quick and efficient way to obtain additional 
information on the web and other locations. Adobe 
Acrobat auto-detects implicit hyperlinks which means 
any spelled-out url or email address is detected and that 
link make clickable within the application. This can be 
misleading because it gives the illusion that all of those 
links are both clickable and accessible. However those 
links are only clickable and not at all accessible. For this 
reason it’s important to properly create hyperlinks in 
Microsoft word so that those links are properly tagged 
and accessible to users of assistive technology.

To create a hyperlink in Microsoft Word, simply select 
the text that you want to add a link to. Then right-click on 
the selected text and choose Link. The Insert Hyperlink 
dialog box will appear providing you with several options 
for the type of link you want to create. You can create the 
following types of links in the Insert Hyperlink dialog box:

• Link to an existing file or web page
• Link to a location in the document
• Link to an email address

Choose the type of link that you want to create and 
then enter the destination url (if appropriate). Click OK 
and the link will be created.

The importance of performing this step is that now 
when the PDF file is generated, that link will contain 
a <Link> tag with a Link-OBJR object within that tag 
making that hyperlink accessible to users of assistive 
software.

Screen tips
When trying to meet PDF/UA compliance, an additional 
requirement for hyperlinks is that each hyperlink contains 
alternate text. This may seem like overkill, but it stems 
from a time when it was common to use phrases such 
as “click here” for a hyperlink which isn’t very descriptive 
and doesn’t tell a reader where the link is taking them. 
Microsoft Word allows you to add alternate text to 
hyperlinks by clicking on the ScreenTip button at the top-
right of the Insert Hyperlink dialog box. Here you can add 
descriptive text that will satisfy the alt-text requirement.
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Creating a hyperlink in Microsoft Word.

Creating a Table of Contents
A table of contents can be a significant benefit to both 

sighted users and users of assistive technology. Creating 
them however needs to be done properly in order for 
the table of contents to function and be accessible. The 
key to generating an accessible table of contents is to 
simply leverage the table of contents feature in Microsoft 
Word. By using this feature, the table of contents in the 
exported PDF file will create links for all of the table of 
contents entries that will link to the appropriate section 
of the document. In addition, the table of contents in 
the exported PDF file will be properly tagged. Word 
generates a table of contents based on the heading styles 
used in the document. Each heading becomes an entry in 
the table of contents when it is created.

To create a table of contents in Microsoft Word, start 
by inserting your cursor in the document where you 
would like the table of contents to appear. Click on the 
References tab at the top of the Ribbon and click the 
Table of Contents button. Word is pretty intelligent here 
as it will automatically generate some Automatic Tables 
of Contents form which you can choose. There’s also an 
option at the bottom of the list called Custom Table of 
Contents that you can choose if you want to customize 

the table of contents to your liking. For this example, let’s 
choose an Automatic Table of Contents and you’ll see that 
the table of contents is inserted at your cursor location.

A table of contents in Word is dynamic which means 
it maintains an association to the data that is generating 
the entries in the table of contents. So as you’re working, 
if you decide to add, remove, or adjust any of the content 
in the document, you can simply update the table of 
contents with the new information. To update a table of 
contents in Microsoft Word, click anywhere within the 
table of contents, and click the update badge at the top 
of the table of contents. In the resulting Update Table of 
Contents dialog box, you can choose whether to update 
the entire table of contents or the page numbers only. 
Choosing either option and clicking OK will update the 
table of contents appropriately.
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Inserting a Table of Contents in Microsoft Word.

Updating a Table of Contents in Microsoft Word.

Working with Images
Images require special attention when it comes to 
accessibility because fundamentally images contain 
no relevant information. Assistive software will voice 
an image as “graphic” but beyond that there’s no 
information about the image that can be read.

That’s where alternate text comes into play. Alternate 
text or Alternative text is text that describes in image in 
its context. Think about if you had to describe what you 
are seeing in an image. This is the job of alternate text. 
For more information on writing good alternate text, read 

this article from WebAIM that discusses the topic in more 
detail.

Conversely, sometimes images are used in a document 
strictly for aesthetic reasons. They’re used to add visual 
interest in a document but they really don’t have much 
value in the context of the content of the document. 
For these images, a common practice is to artifact them. 
Artifacting is a term used to describe images that should 
not be read by assistive software. When an image is 
artifacted, assistive software ignores it as if it weren’t in 
the document at all.

To add alternate text to an image in Microsoft Word, 
click on the image to select it, then right click on the 
selected image and choose Edit Alt Text. Alt alt text pane 
will appear containing a field in which you can type the 
alternate text for the selected image.

If you’re using a recent version of Microsoft Word, you 
may also notice a check box at the bottom of the Alt Text 
pane called “Mark as decorative”. This check box when 
enabled will artifact the image so it is not read by assistive 
software.

Adding alternate text for an image in the Alt Text pane in Microsoft 
Word.

https://webaim.org/techniques/alttext/
https://webaim.org/techniques/alttext/
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Tag Order
In addition to the tags themselves, the order in which the 
tags appear in a PDF file is of utmost importance. This is 
because the order in which the tags appear in the Tags 
pane of Adobe Acrobat is the order in which assistive 
software applications such as JAWS and NVDA read the 
content in a document.

If care is not taken to ensure that the tag order 
is correct, the experience to the end user could be 
confusing and not make sense.

Reading Order
PDF documents contain an addition order of objects 
beyond the Tag Order which is referred to as the Reading 
Order. The Reading Order is visible in Adobe Acrobat 
when the Reading Order tool is activated or when the 
Order panel is activated. As stated before, although JAWS 
and NVDA utilize the tag order to determine the order in 
which content is read, some assistive technologies use the 
Reading Order instead. So to ensure that all technologies 
can read an accessible PDF file that you generate, and to 
meet WCAG success criteria 1.3.2, both orders need to 
be properly defined in an accessible PDF file to ensure 
that the document can be read by all users and all 
technologies.
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